Rasp HiFiBerry-Upgrade-Kernel

De MCHobby - Wiki
Aller à : navigation, rechercher

MCHobby investit du temps et de l'argent dans la réalisation de traduction et/ou documentation. C'est un travail long et fastidieux réalisé dans l'esprit Open-Source... donc gratuit et librement accessible.
SI vous aimez nos traductions et documentations ALORS aidez nous à en produire plus en achetant vos produits chez MCHobby.

La mise-à-jour du noyau/kernel

Les cartes HiFiBerry Digi et DAC sont supportées par le noyau Linux actuel du Raspberry Pi. Cependant, la plupart des distributions n'utilisent pas la toute dernière version du noyau. Par conséquent, vous pourriez avoir besoin de mettre votre noyau à jour. Cette opération est relativement facile avec de nombreuses distribution. Voici un petit guide pour vous aider.

Note: Faites toujours une copie de sauvegarde avant de faire une mise-à-jour du noyau! Il y a de nombreuses choses qui peuvent fonctionner de travers. Une perte d'alimentation durant la mise-à-jour rendra le système totalement inutilisable, mais vous pourriez également faire face à des incompatibilités.

Raspbian

La mise-à-jour la plus facile est encore celle de le distribution "officielle" pour Rapsberry. Installez le paquet rpi-update puis faite une mise-à-jour du noyau avec les commandes:

sudo apt-get install rpi-update
sudo rpi-update

OpenElec

OpenElec utilise un système de fichier et un noyau vraiment spécial. Cela ne se résume pas à une simple mise-à-jour du noyau.

Voyez cette section du tutoriel spécialement consacré à OpenElec et une autre section à OpenElec 5

Autres distributions (ex: Raspbmc)

Sur beaucoup d'autres distributions, rpi-update fonctionnera. Cependant, il est difficile de le garantir (comme le mentionne la doc d'HiFiBerry), c'est quelque-chose que vous devez essayer vous même. Si vous avez des données importantes sur votre système alors n'oubliez pas d'en faire une copie avant la mise-à-jour!

Il y a plusieurs options disponibles pour installer rpi-update:

  • via l'utilitaire apt-get
  • via l'utilitaire Git

Installer rpi-update avec apt-get

Faire une mise-à-jour des dépôts

sudo apt-get update

La façon la plus facile d'installer le paquet rpi-update est d'utiliser l'outil apt-get:

sudo apt-get install -y rpi-update

Cependant, sur certaines distribution, le dépôt rpi-update n'est pas configuré. Dans ce cas, vous obtiendrez un message d'erreur tel que celui-ci:

 E: Unable to locate package rpi-update

Ce message signifie impossible de localiser le paquet rpi-update

Dans ce cas, il sera nécessaire de passer par une procédure plus complexe qui consiste à installer rpi-update depuis GitHub en utilisant git.

Installer rpi-update via GIT

Pour commencer, il faut installer git, curl et binutils

 sudo apt-get install -y git-core curl binutils

L'utilitaire apt-get pourrait ne pas fonctionner si vous n'utilisez pas une distribution basée sur Debian. Voyez la documentation de votre distribution pour savoir comment installer git. Il se pourrait d'ailleurs que cet utilitaire soit déjà installé.

Sur de nombreuses distributions Debian il est nécessaire de faire une mise-à-jour du certificat SSL (avant de commencer les autres opérations).

sudo apt-get install -y ca-certificates

Ensuite, vous pouvez installer rpi-update via git

sudo wget https://raw.github.com/Hexxeh/rpi-update/master/rpi-update -O /usr/bin/rpi-update && sudo chmod +x /usr/bin/rpi-update

Mise-à-jour du noyau

Maintenant, vous pouvez exécuter rpi-update

sudo /usr/bin/rpi-update

Si vous n'utilisez pas de système dérivé de Debian, vous pourriez avoir un message d'erreur comme celui-ci:

You appear to be trying to update firmware on an incompatible distribution.

Signifiant: Vous essayez de mettre le firmware à jour sur une distribution incompatible.

Dans ce cas, utilisez la ligne de commande suivante:

sudo -E RPI_UPDATE_UNSUPPORTED=0 rpi-update



Tutoriel Updating the Linux kernel créé par HiFiBerry.com.

Tutoriel traduit par Meurisse D. pour MCHobby.be

Traduit avec l'autorisation de HiFiBerry - Translated with the permission from HiFiBerry - hifiberry.com

Toute référence, mention ou extrait de cette traduction doit être explicitement accompagné du texte suivant : «  Traduction par MCHobby (www.MCHobby.be) - Vente de kit et composants » avec un lien vers la source (donc cette page) et ce quelque soit le média utilisé.

L'utilisation commercial de la traduction (texte) et/ou réalisation, même partielle, pourrait être soumis à redevance. Dans tous les cas de figures, vous devez également obtenir l'accord du(des) détenteur initial des droits. Celui de MC Hobby s'arrêtant au travail de traduction proprement dit.